Pan/Tilt servo issue

Added by Jeff Randall over 6 years ago

I just received my Pixy and Pan/Tilt kit today. The Pixy works fine by itself. But as soon as I connected the servos and power up the Pixy, both servos began to turn to the right and continued trying to turn right even when they hit their stops. I was using a 3ft USB cable that I considered to be a decent cable. I read the note in the Wiki about using a shorter USB cable. So, I tried a 1ft USB cable, that I have, and now the servos center and stop when the Pixy is plugged in.

This 1ft USB cable is too stiff and short and causes the Pixy to skid around and flip over while running the pan/tilt demo. Is there an alternate way to power the Pixy? Or where can I find a longer USB cable that is flexible and doesn't have too much electrical resistance?

I'm going to try a powered USB hub tomorrow, to see if that will help. I'll report back what I find.


Replies (6)

RE: Pan/Tilt servo issue - Added by Scott Robinson over 6 years ago

Hi Jeff,

Please do let us know what you find so we can help others who have the same problem.

I can't give you a recommendation on USB cables as I haven't been able to try out too many myself (Rich probably has, so I'll see if I can get suggestions from him). As for powering the Pixy, you can try using an Arduino. Just connect the provided Arduino cable to a powered Arduino and you're good to go. You can also use batteries, but I'd suggest trying the Arduino or a different USB cable first, since its easier to set up.

Scott

RE: Pan/Tilt servo issue - Added by Jeff Randall over 6 years ago

Thanks, I'll try connecting one of my Arduinos.

I tried a 7 port Belkin USB hub with a 4 amp power supply and a 4 port CyberPower hub with a 2.5 amp supply. It didn't help. Both had the same problem using my 3ft USB cable. So, I'm also going to go in search of a better USB cable. I'll report back what I come up with.

RE: Pan/Tilt servo issue - Added by Jeff Randall over 6 years ago

Okay, I found two different 6 foot USB cables that work great on my PC! Here are links to them on Amazon.com:

http://www.amazon.com/gp/product/B001TH7GUK/ref=oh_details_o01_s00_i01?ie=UTF8&psc=1

http://www.amazon.com/gp/product/B0013LQD7Y/ref=oh_details_o01_s00_i00?ie=UTF8&psc=1

Both are priced under $6. The first is an Amazon Basics cable. It is very flexible and works well. The second is a little stiffer. But, it connects to two USB ports to allow more current to the Pixy. It should work well for anyone that has problems using a single USB port.

RE: Pan/Tilt servo issue - Added by Scott Robinson over 6 years ago

This is great! Thanks for posting your findings, Jeff. I'll record this in case we expand the wiki to include info like this.

Scott

RE: Pan/Tilt servo issue - Added by Chris W over 6 years ago

http://cmucam.org/projects/cmucam5/wiki/Powering_Pixy explains how to connect a better power supply.

RE: Pan/Tilt servo issue - Added by Pablo Aizpiri about 5 years ago

I ran into the same issues... buying those cables now.

(1-6/6)