pan/tilt servo malfunction

Added by shoaib mohamed 9 months ago

I recently purchased a pixy and pan/tilt kit but I am having issues with it. The servos go crazy out of control when I try to run the demo from pixymon, also the same case when running it from Arduino. I was using a very short cable of about 1ft long and then I changed to a longer cable of about 3ft and the problem still remains. I have also tried many solutions listed in the forum but nothing helps.

Please help me out on this as soon as possible because I am using pixy for my university project and I need to come up with a solution.


Replies (3)

RE: pan/tilt servo malfunction - Added by Edward Getz 9 months ago

Hello Shoaib,
Make sure you're not using a USB hub, or perhaps your servo wires are reversed. Have you seen this guide?

Also make sure that your Pixy has a good lock on the object you are trying to detect.


RE: pan/tilt servo malfunction - Added by tony hallen 6 months ago

My servos pan/tilt to max position, then sit there jittering.

I tried adjusting frequency (default is 60) and reducing range (default is -200 - +200).

I connected 2 similar 9oz servos and they worked correctly with freq = 75.

Any suggestions as to adjusting settings or other fixes for the original servos? Different manufacturers' servos might need different settings?

Any help is appreciated.

RE: pan/tilt servo malfunction - Added by Jesse French 6 months ago

Hi Tony,

sounds like a power issue. How are you powering Pixy and Pan/Tilt?