Raspbian Strecth on Raspberry Pi : error if pixyMon autonomous

Added by François MOCQ 2 months ago

Hello
I start with a fresh installation of Raspbian strecth.
update & upgrade ok
i install Qt
then pixymon with :
git clone https://github.com/charmedlabs/pixy.git
and build pixyMon
PixyMon works on this microSD board when launched from a terminal

copy the directory of the executable file to another board
but when i launch pixymon, I have this message and it did not start

pi@raspberrypi:~/pixy $ ./PixyMon
./PixyMon: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by ./PixyMon)
./PixyMon: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./PixyMon)

If any one have an idea? i found some forums where they speak about a version of libstdc++ problem
but i don not know how i can solve this

best regards
francois
www.framboise314.fr


Replies (2)

RE: Raspbian Strecth on Raspberry Pi : error if pixyMon autonomous - Added by Edward Getz 2 months ago

Hello Francois,
These messages mean that your other computer is missing some of the libc runtime libraries, or the ones that are installed are of a different version. With Linux, we recommend compiling Pixymon on the same computer, which will prevent these kinds of issues. If you're unable to compile on the same computer, you will need to make sure they use the same shared objects/libraries. There are other solutions, like static linking, but this requires modifying the makefile/is more advanced.

Edward

RE: Raspbian Strecth on Raspberry Pi : error if pixyMon autonomous - Added by François MOCQ 2 months ago

Hello Edward

thank you for information
I say my readers to use PixyMon on the same computer where they compile
best regards
François

(1-2/2)